Ospf là gì

OSPF – Open Shordemo Path First, là một trong giao thức định đường links – state nổi bật. Đây là 1 trong giao thức được sử dụng rộng thoải mái trong số mạng công ty tất cả size to. Trong lịch trình CCNA, đây cũng là 1 trong chủ đề bao gồm được kể các. Do đó, nắm vững đầy đủ cách thức hoạt động của OSPF để giúp chúng ta đã theo học chương trình CCNA xong tốt kỳ thi đem chứng chỉ quốc tế CCNA cũng giống như đáp ứng nhu cầu xuất sắc nhu cầu công việc vào thực tiễn.Quý khách hàng đã xem: Ospf là gì

Một số điểm lưu ý bao gồm của giao thức OSPF:

OSPF là một giao thức link – state điển hình nổi bật. Mỗi router Lúc chạy giao thức đã gửi các trạng thái đường link của chính nó mang lại tất cả những router vào vùng (area). Sau một thời gian hiệp thương, các router đang đồng bộ được bảng các đại lý tài liệu trạng thái đường liên kết (Link State Database – LSDB) với nhau, từng router đều phải có được “phiên bản đồ dùng mạng” của cả vùng. Từ đó mỗi router đang chạy giải thuật Dijkstra tính toán thù ra một cây lối đi nđính thêm tốt nhất (Shorkiểm tra Path Tree) và dựa vào cây này để xây hình thành bảng định tuyến.OSPF tất cả AD = 110.Metric của OSPF còn được gọi là cost, được xem theo bandwidth bên trên cổng chạy OSPF.OSPF chạy thẳng bên trên nền IPhường., gồm protocol – id là 89.OSPF là một trong giao thức chuẩn quốc tế, được quan niệm vào RFC – 2328.

Bạn đang xem: Ospf là gì

Ta cùng Reviews hoạt động vui chơi của OSPF thông qua các bước chuyển động nlỗi sau:

Bầu chọn Router – id.Thiết lập dục tình trơn giềng (neighbor).Trao đổi LSDB.Tính toán thù gây ra bảng định con đường.

Router – id:

Đầu tiên, khi một router chạy OSPF, nó nên chỉ ra rằng một quý hiếm dùng làm định danh tuyệt nhất mang lại nó vào xã hội những router chạy OSPF. Giá trị này được Điện thoại tư vấn là Router – id.

Router – id bên trên router chạy OSPF tất cả định dạng của một ảnh hưởng IPhường. Mặc định, tiến trình OSPF trên mỗi router vẫn tự động hóa bầu lựa chọn quý hiếm router – id là liên hệ IP tối đa trong các interface đã active sầu, ưu tiên cổng loopbachồng.

Ta thuộc hiểu rõ ý này trải qua ví dụ:


*

Hình 1 – Bầu chọn router – id (1).

lúc cho router R tđê mê gia OSPF (xem hình 1), router R phải thai chọn ra một ‘nick name’ để định danh R khi R chạy OSPF. Vì ‘nick name’ này còn có định dạng của một can hệ IPhường cần R đã mang một trong số can dự IP trên nó để triển khai Router – id. Nlỗi vẫn nhắc tới ở bên trên, chỉ liên quan của các interface sẽ active, Có nghĩa là làm việc trạng thái up/up (status up, line protocol up) bắt đầu được tsay mê gia bầu lựa chọn. Ta thấy bên trên hình , chỉ gồm hai cổng F0/0 và F0/1 của R là up/up đề nghị router R đã chỉ chú ý hai tương tác bên trên nhì cổng này là 192.168.1.1 cùng 192.168.2.1. Để xác minh trong hai tương tác này, ảnh hưởng làm sao là cao hơn, R triển khai so sánh nhị ảnh hưởng này theo từng octet trường đoản cú trái lịch sự đề xuất, thúc đẩy làm sao gồm octet đầu tiên to hơn được xem như là lớn hơn. Ta thấy, với phương pháp đối chiếu này, hệ trọng 192.168.2.1 được xem là to hơn địa chỉ 192.168.1.1 vì thế nó sẽ tiến hành áp dụng để gia công router – id. Vậy R vẫn tđắm đuối gia OSPF với giá trị ‘nick name’ – router id là 192.168.2.1.

Cũng ví dụ trên dẫu vậy lần này trên router R bao gồm thêm những interface loopback :


*

Hình 2 – Bầu lựa chọn router – id (2).

Khi ta nhảy OSPF bên trên router R, R xúc tiến Việc bầu chọn router – id. Vì lần này có những interface loopbachồng bắt buộc R sẽ bỏ qua mất, không để ý các tương tác của các interface đồ dùng lý. Hai liên tưởng của nhị interface loopbachồng 1 cùng 2 sẽ tiến hành so sánh nhằm lựa chọn ra router – id mang lại router R, và ta thấy rõ ràng 2.2.2.2 > 1.1.1.1 buộc phải router R sẽ lựa chọn 2.2.2.2 làm cho router – id lúc tsi gia OSPF. Từ hình 2, ta thấy, 2.2.2.2 không hẳn là liên quan IPhường tối đa dẫu vậy bởi quá trình ưu tiên cổng loopback buộc phải các liên hệ trên những cổng loopbaông chồng sẽ được cẩn thận trước. Vấn đề này được giải thích là đã mang về sự ổn định cho các bước OSPF vị interface loopback là các loại interface luận lý ko bao giờ down trừ khi tín đồ quản lí trị shutdown interface này.

Thực hóa học, việc up/down của các interface không ảnh hưởng các lắm đến router – id của những router chạy OSPF. Thật vậy, đưa sử vào ví dụ bên trên, router R vẫn chọn dứt router – id là 192.168.2.1 là IP.. của cổng F0/1 (xét ngôi trường phù hợp chưa xuất hiện các interface loopback) với tyêu thích gia vào OSPF cùng với router – id 192.168.2.1. Hiện giờ, giả dụ ta bao gồm bổ sung thêm những interface loopbaông xã bên trên router thì router cũng trở nên không thay đổi lại router – id thành IPhường của các interface loopbaông chồng. mà hơn nữa, mặc dù bây giờ cổng F0/1 gồm down, thì router vẫn giữ lại quý hiếm router – id mà lại nó đã chọn. Tức là, router – id 1-1 thuần chỉ nên một chiếc thương hiệu. Lúc tên đã có lựa chọn thì quy trình OSPF sẽ thao tác làm việc cùng với cái thương hiệu này với không chuyển đổi lại nữa. Cổng gồm IPhường. được trích xuất làm tên của router bây giờ bao gồm up/down cũng ko tác động gì cả. Vậy nếu bọn họ hy vọng đổi lại router – id của tiến trình thì sao? Ta đề xuất thực hiện khởi hễ lại router hoặc gỡ vứt quá trình OSPF rồi cấu hình lại, lúc đó quy trình thai lựa chọn router – id sẽ được triển khai lại với những interface đã hiện hữu bên trên router.

Và như thế, ta thấy vấn đề ưu tiên sử dụng IPhường bên trên loopbachồng mang nhiều chân thành và ý nghĩa về mặt quản lí trị hơn là tính bình ổn của các bước. Nó có thể chấp nhận được ngươi cai quản trị kiểm soát và điều hành kết quả hơn những router – id của những router.

Có một bí quyết không giống nhằm thiết lập lại giá trị router – id cho router mà không cần phải khởi đụng lại router hoặc thông số kỹ thuật lại OSPF là thực hiện câu lệnh ‘router-id’ để tùy chỉnh thiết lập thủ công quý hiếm này bên trên router:

Router(config)#router ospf 1

Router(config-router)#router-id A.B.C.D

Hiện nay giá trị của router – id rất có thể không cần phải là 1 trong những hệ trọng IP.. bao gồm sẵn trên router. Dường như, ví như quy trình OSPF vẫn chạy cùng router – id đã được thiết lập trước kia, ta nên khởi cồn lại các bước OSPF thì mới có thể áp dụng giá tốt trị router – id mới được đã cho thấy vào câu lệnh ‘router – id’. Câu lệnh khởi đụng lại quy trình OSPF:

Router#clear ip ospf process

Rephối ALL OSPF processes? : yes Area – id.Hello timer cùng Dead timer.Hai xúc tiến IP.. đấu nối cần thuộc subnet (một vài ba ngôi trường thích hợp còn thưởng thức cùng cả subnet – mask).Thỏa mãn các điều kiện tuyệt đối.Cùng nhảy hoặc cùng tắt cờ stub.Ta cùng so sánh từng thông số đang nêu sinh sống trên.

Area – id

Nguyên tắc hoạt động của OSPF là mỗi router bắt buộc ghi ghi nhớ bảng các đại lý dữ liệu tâm lý mặt đường links của toàn cục khối hệ thống mạng chạy OSPF rồi từ đó tiến hành tính toán thù định con đường dựa trên bảng cửa hàng tài liệu này. Để bớt cài bộ nhớ cũng tương tự download tính toán thù cho mỗi router cùng bớt thiểu lượng biết tin định tuyến yêu cầu đàm phán, các router chạy OSPF được phân thành các vùng (area), mỗi router bây giờ chỉ việc buộc phải ghi lưu giữ thông tin cho 1 vùng nhưng mà nó làm việc trong số ấy (hình 4).

Hình 4 – Kiến trúc phân vùng vào OSPF.

Cách tổ chức như thế rõ ràng tiết kiệm ngân sách tài ngulặng mạng cùng tài nguyên ổn trên từng router. Trong khi, bí quyết tổ chức này còn xa lánh được hầu như không ổn định vào trong một vùng: Khi tất cả một liên kết nào kia trên một router up/down, sự khiếu nại này chỉ Viral trong nội cỗ một vùng và gây ra sự tính tân oán lại định đường của những router trong vùng ấy chứ không hề ảnh hưởng mang đến những router nằm trong vùng không giống.

Mỗi vùng được chỉ ra sẽ sở hữu một quý hiếm định danh mang lại vùng Gọi là Area – id. Area – id hoàn toàn có thể được hiển thị dưới dạng một trong những tự nhiên hoặc dưới dạng của một can hệ IP.. Vi dụ Area 0 có thể được màn trình diễn là Area 0.0.0.0. Một nguyên lý yêu cầu vào phân vùng OSPF là trường hợp chia thành các vùng thì bắt buộc phải tồn tại một vùng sở hữu số hiệu 0 – Area 0, Area 0 nói một cách khác là Backbone Area với gần như vùng khác sẽ phải có liên kết nối về vùng 0.

khi thực hiện cấu hình phân vùng mang đến router, ta không gán cả router vào một trong những vùng mà tiến hành gán link trên router vào một trong những vùng. Area – id được gán mang đến liên kết của router chứ đọng chưa phải gán cho bạn dạng thân router. Ví dụ: bên trên hình 4, ta thấy cục bộ router R2 bên trong vùng 0 là vì Khi thông số kỹ thuật ta đã gán nhị link bên trên R2 vào vùng 0. Những router mà lại bao gồm tất cả các links đầy đủ được gán vào một vùng thì sẽ lọt hẳn vào vùng kia cùng được gọi là các Internal router, các Internal router chỉ đề nghị ghi ghi nhớ tâm trạng đường links của vùng cơ mà nó ở phía bên trong. Ta cũng xét tiếp router R4. Router này có một links ở trong vùng 0, lại có một links nằm trong vùng 1, những điều đó nó ở trong về cả nhị vùng cùng đề xuất ghi ghi nhớ tâm trạng mặt đường link của tất cả nhị vùng. Những router như vậy được call là các router ABR – Area Border Router – router biên giới thân hai vùng.

khi nhì router láng giềng kết nối với nhau sang một link, bọn chúng đề nghị thống tuyệt nhất với nhau về area – id của link này. Cả hai router buộc phải gán cùng một số trong những area – id cho link liên kết thân chúng cùng nhau. Nếu vấn đề này bị phạm luật, bọn chúng sẽ không thể thiết lập cấu hình được quan hệ nam nữ láng giềng trải qua link này và cho nên ko lúc nào hoàn toàn có thể hiệp thương được ban bố định tuyến đường qua liên kết. Đó là ĐK thứ nhất vào câu hỏi thiết lập cấu hình quan hệ giới tính nhẵn giềng: thống tốt nhất về area – id bên trên liên kết kết nối.

Chương trình CCNA không đề cập đến OSPF nhiều vùng mà lại chỉ nói tới OSPF đơn vùng, trong những số ấy mọi router hồ hết được gán vào một trong những vùng. Kiến trúc nhiều vùng với những vụ việc cụ thể của nó sẽ được đề cập chi tiết trong course Route của chương trình CCNP..

Hello timer cùng Dead timer

Hello timer là khoảng chừng thời gian chu kỳ gửi gói tin hello ra khỏi một cổng chạy OSPF. Lúc một router nhận thấy hello trường đoản cú nhẵn giềng, nó vẫn khởi động Dead timer. Nếu sau khoảng thời gian được đã cho thấy trong Dead timer mà router không sở hữu và nhận được gói tin hello tự láng giềng, nó đang coi nhỏng bóng giềng này không còn với đang xóa rất nhiều thông tin mà nó học tập được từ bỏ láng giềng. Ngược lại, cứ đọng mỗi lần nhận thấy gói tin hello từ láng giềng, Dead timer lại được rephối. Giá trị khoác định của hello – timer và dead – timer là 10s với 40s. Ta hoàn toàn có thể hiệu chỉnh những quý giá này bên trên cổng chạy OSPF bằng cách áp dụng câu lệnh:

R(config-if)#ip ospf hello-interval  seconds

Để nhì router cấu hình thiết lập được tình dục bóng giềng với nhau, cặp quý hiếm này sẽ phải khớp nhau bên trên nhì router sinh hoạt nhì đầu của mặt đường liên kết.

Cùng subnet

Hai xúc tiến IP1 và IP2 đấu nối nhau giữa hai router cần phải thuộc subnet thì hai router này new rất có thể tùy chỉnh thiết lập quan hệ nhẵn giềng với nhau (coi hình 3). Một số trường thích hợp còn yêu cầu nhì cửa hàng này cần thuộc cả subnet – mask nhằm hoàn toàn có thể tùy chỉnh cấu hình neighbor.

Thỏa mãn authentication

Trong ngôi trường đúng theo để tăng tốc tính bảo mật của chuyển động thương lượng công bố định tuyến đường, họ thực hiện setup những pasword trên nhị router hai đầu đường links. Yêu cầu nên là hai password này nên khớp nhau làm việc hai đầu để nhị router có thể tùy chỉnh neighbor (vớ nhiên!). Cấu hình chuẩn xác không đúng hoàn toàn có thể dẫn đến ko thiết lập neighbor được thân nhị router từ bỏ đó dẫn mang lại không trao đổi được ban bố định con đường.

Cờ stub

Trong phong cách thiết kế đa vùng của OSPF tất cả một một số loại vùng call là vùng stub. Vùng stub là vùng ko mừng đón LSA type – 5. khi ta đang cho 1 link của một router thuộc vùng stub thì cần đầu cơ của links cũng phải gán links này nằm trong vùng stub. Khi đó các gói tin định tuyên ổn hiệp thương nhau giữa nhị đầu sẽ sở hữu cờ stub được nhảy lên. Chi tiết về vùng stub được nhắc cụ thể vào course Route của lịch trình CCNPhường, công tác CCNA không cover sự việc này.

Sau Lúc cả 05 ĐK nêu bên trên đã được thỏa mãn, hai router tùy chỉnh thiết lập với nhau một mối quan hệ call là dục tình láng giềng cùng được ký hiệu là 2 – WAY. Khi các router đang cấu hình thiết lập được quan hệ giới tính 2 – WAY với nhau, bọn chúng ban đầu triển khai dàn xếp bảng cơ sở tài liệu tinh thần con đường link (LSDB – Link State Database) lẫn nhau. Việc thương lượng này được sải ra toàn mạng cùng sau cuối từng router đều phải có được tâm lý mặt đường liên kết của những router trong mạng, từ đó bọn chúng tiến hành tính tân oán bên trên cửa hàng tài liệu trạng thái con đường links này với thiết kế bảng định tuyến đường.

Trao đổi LSDB

LSDB – Link State Database – Bảng cửa hàng tài liệu trạng thái mặt đường links là 1 bảng bên trên router ghi ghi nhớ phần lớn tinh thần đường link của hầu hết router trong vùng. Ta rất có thể coi LSDB là một trong “tấm phiên bản đồ gia dụng mạng” mà lại router vẫn căn cứ vào kia để tính toán định đường. LSDB đề nghị trọn vẹn như là nhau giữa những router cùng vùng. Các router sẽ không thảo luận cùng nhau cả một bảng LSDB nhưng sẽ trao đổi cùng nhau từng đơn vị chức năng báo cáo Call là LSA – Link State Advertisement. Các đơn vị thông báo đó lại được chứa trong những gói tin rõ ràng điện thoại tư vấn là LSU – Link State Update cơ mà những router đích thực hiệp thương cùng nhau. Lưu ý: LSA không phải là 1 trong những loại gói tin nhưng chỉ với một bản tin. LSU new thực thụ là gói tin và nó tiềm ẩn các phiên bản tin này.

Việc Bàn bạc thông tin ra mắt cực kỳ khác nhau tùy theo từng nhiều loại network – type gán cho link thân nhì router. Trong kích thước chương trình CCNA, họ chỉ xét cho nhị loại network – type là Point – to – Point và Broadcast Multiaccess.

Point – lớn – point

Loại links point – to lớn – point điển hình là kết nối serial điểm – điểm chạy giao thức HDLC hoặc PPP nối thân nhị router (hình 5).

Hình 5 – Trao thay đổi LSDB cùng với liên kết point – to lớn – point.

Trong ngôi trường đúng theo này, hai router nhẵn giềng sẽ ngay lập tức lập tức gửi cục bộ bảng LSDB lẫn nhau qua liên kết point – to – point và gửi tâm trạng quan hệ tự 2 – WAY qua một mức độ bắt đầu Call là tình dục dạng FULL. Quan hệ Full qua 1 liên kết serial point – khổng lồ – point được cam kết hiệu là FULL/ – .

Broadcast Multiaccess

Môi trường Broadcast Multiaccess điển hình chính là môi trường Ethernet LAN (hình 6).

Hình 6 – Broadcast MultiAccess.

Việc trao đổi LSDB ra mắt hoàn toàn khác trong môi trường xung quanh này. Với môi trường thiên nhiên này, từng router phần đa liên kết thẳng với nhau cùng những tùy chỉnh thiết lập tình dục 2 – WAY cùng nhau. Tuy nhiên, những router sẽ không hội đàm trực tiếp với nhau nhưng mà sẽ triển khai dàn xếp biết tin thông qua 1 router đầu mối Gọi là DR – Designated Router. Trên từng kết nối Multi – access, một DR router được bầu ra. Một router khác sẽ được thai có tác dụng Backup DR (BDR) để tham gia phòng mang lại DR trong trường thích hợp DR down. Các router còn sót lại đóng vai trò là DROther. Nguyên ổn tắc đặt ra nhỏng sau: các router DROther Khi thương lượng đọc tin định con đường sẽ không gửi trực tiếp cho nhau nhưng mà đã trình lên cho DR cùng BDR. Sau kia router DR này sẽ forward lại lên tiếng xuống cho những router DROther khác. Khi các router gửi ban bố lên cho DR và BDR, chúng sẽ áp dụng liên hệ multicast 224.0.0.6 còn lúc DR forward lại báo cáo xuống những router không giống, nó sử dụng liên hệ 224.0.0.5. Nhắc lại, những DROther ko thương lượng trực tiếp cùng nhau.

Về quan hệ giới tính giữa các cặp router bây giờ, ta thấgiống hệt như sau:

– Các DROther không khi nào Bàn bạc đọc tin cùng nhau yêu cầu quan hệ nam nữ thân chúng vĩnh cửu chỉ dừng lại tại mức độ 2 – WAY. Thực hiện show bảng neighbor bên trên các router DROther đang thấy rằng những router này hiển thị triệu chứng dục tình cùng nhau là 2-WAY/DROther.

Xem thêm: Phẫu Thuật Thành Công Bệnh Lý Động Mạch Chủ Ngực, Bệnh Lý Động Mạch Chủ

– Các DROther có trao đổi dữ liệu cùng với DR với BDR đề xuất trong bảng neighbor của các router DROther, các router DR và BDR đã hiện ra với quan hệ giới tính dạng full: FULL/DR cùng FULL/BDR. Ngược lại, những router DR và BDR cũng thấy triệu chứng tình dục của những router DROther cùng với bọn chúng là FULL/DROther.

do đó, router DR đóng một sứ mệnh siêu quan trọng trên môi trường thiên nhiên Multiaccess: sẽ là router điều phối hận thông báo bên trên môi trường này. Vậy router làm sao sẽ được chọn có tác dụng DR? Ta có nguyên lý bầu chọn DR cùng BDR cho 1 môi trường thiên nhiên multi – access như sau:

– Trên từng cổng đấu nối multi – access của mỗi router đều phải có một giá trị hotline là priority. Giá trị priority này nằm trong dải từ bỏ 0 mang đến 255 cùng được hội đàm thân những router trong các gói tin hello. Router làm sao nắm giữ giá trị priority cao nhất sẽ tiến hành thai chọn làm cho DR, priority cao hai làm cho BDR, sót lại đã là DROther. Giá trị priority mặc định bên trên các cổng router là bởi 1. Lưu ý rằng trường hợp router có quý giá priority bởi 0 sẽ không tđắm đuối gia vào quy trình bầu lựa chọn DR cùng BDR, nó luôn luôn luôn luôn phụ trách vai trò là DROther.

– Trong trường hòa hợp giá trị priority cân nhau (ví dụ để mang định bởi 1 hết, ko thông số kỹ thuật gì thêm), router làm sao có Router – id cao nhất sẽ làm DR, Router – id cao hai sẽ làm cho BDR, còn lại có tác dụng DROther. Ta nói Router – id là tie – breaker của Priority.

Có một số chú ý đến bài toán thai lựa chọn DR cùng BDR nhỏng sau:

– Nếu ta thông số kỹ thuật một router nhận giá trị priority bằng 0, router này sẽ không tham gia vào các bước thai lựa chọn DR và BDR, nó luôn luôn là DROther. Chúng ta nên lưu ý vấn đề đó bởi giả dụ bọn họ cấu hình mang lại toàn bộ những router đấu nối vào môi trường xung quanh multi – access giá trị priority = 0 thì vẫn không có router làm sao Chịu đựng làm DR mang đến môi trường này! Lỗi này dẫn mang đến lỗ hổng vào việc hội đàm biết tin định con đường.

– Luật bầu lựa chọn DR là non – preempt: lúc một DR đã có được bầu lựa chọn kết thúc, nếu router new tmê say gia vào môi trường multi – access tất cả priority giỏi router – id cao hơn nữa router DR nó cũng cần yếu chỉ chiếm quyền của DR bây chừ. Chỉ lúc nào DR hiện giờ down, router khác new tất cả cơ hội trỡ quyền DR.

– Một router rất có thể đóng nhiều sứ mệnh khác nhau trên nhiều cổng multi – acces khác biệt. Ví dụ: nó rất có thể là DR bên trên môi trường thiên nhiên Multi – access đấu nối vào cổng F0/0 nhưng lại là DROther trên môi trường xung quanh Multi – acces đấu nối vào cổng F0/1.

– Chúng ta ko được lầm lẫn kết nối Ethernet nối 02 router là 1 trong liên kết point – to – point, liên kết này vẫn được xem là Multi – access. Trong ngôi trường đúng theo này, một router vẫn có tác dụng DR, một có tác dụng BDR, không có DROther (hình 8).

Hình 8 – Đây là môi trường xung quanh Multi – access mặc dù chỉ có 02 router.

Sau Khi xong chấm dứt thao tác làm việc hiệp thương LSDB, mỗi router trong vùng đông đảo đã có được bảng cửa hàng dữ liệu tinh thần con đường links của rất nhiều router trong vùng, tốt nói một cách khác, từng router đã sở hữu “tnóng bạn dạng vật mạng” của cả vùng. Dựa trên LSDB này, những router vẫn chạy giải thuật Dijkstra để desgin một cây lối đi ngắn tuyệt nhất mang lại mọi đích cho trong mạng cùng với cội cây đó là router ấy. Từ cây này, router chế tạo lên bảng định tuyến đường của mình. Chi máu về giải mã Dijkstra xin ko kể tại đây. Các chúng ta quan tâm hoàn toàn có thể tò mò trải qua các giáo trình về Toán tách rộc rạc hoặc Lý thuyết đồ thị của các trường Đại học tập. Bài viết này đã giới thiệu giải pháp OSPF tính tân oán metric cho các lối đi cùng phương pháp tín đồ quản ngại trị quan sát vào sơ vật dụng mạng để xác minh đường đi nhưng OSPF sẽ chọn mà lại không phải “chạy” thuật tân oán Dijkstra vào đầu ^^:

Tính tân oán metric với OSPF

Metric trong OSPF được Gọi là cost, được xác định phụ thuộc bandwidth danh định của con đường truyền theo bí quyết nhỏng sau:

Metric = cost = 10^8/Bandwidth (đơn vị chức năng bps).

Ta biệt lập thân bandwidth danh định bên trên cổng với tốc độ thiệt của cổng ấy. Hai giá trị này sẽ không tốt nhất thiết buộc phải trùng nhau và cực hiếm danh định mới chính là quý giá được tham gia vào tính tân oán định tuyến đường. Giá trị danh định được tùy chỉnh trên cổng bằng câu lệnh:

R(config-if)#bandwidth BW(đơn vị chức năng là kbps)

Ta yêu cầu chỉnh cực hiếm danh định này trùng cùng với tốc độ thật của cổng để tách vấn đề tính toán sai lầm trong định tuyến đường. Ví dụ: một đường leased – line liên kết vào cổng serial chỉ bao gồm vận tốc thiệt là 512kbps mà lại cực hiếm bandwidth danh định trên cổng serial luôn là 1 trong những.544Mbps sống mặc định. Điều đó dẫn mang đến OSPF coi một cổng 512 kbps như một cổng 1.544 Mbps! Ta bắt buộc bao gồm lại đường dẫn danh định bên trên cổng trong trường đúng theo này nhằm đề đạt đúng vận tốc thật:

R(config-if)#bandwidth 512

Dựa vào cách làm metric vẫn nêu làm việc bên trên, ta có mức giá trị cost mặc định của một số các loại cổng:

Ethernet (BW = 10Mbps) -> cost = 10.

Fast Ethernet (BW = 100Mbps) -> cost = 1.

Serial (BW = 1.544Mbps) -> cost = 64 (chặt cho chỗ thập phân trong phép chia).

Ta thuộc lưu ý một ví dụ để khảo sát điều tra cách tính toán thù path – cost cho một đường đi:

Hình 9 – Sơ vật ví dụ tính path – cost.

Yêu cầu đặt ra với sơ đồ vật hình 9 là tính path – cost (metric) cho đường đi tự R1 cho mạng 192.168.3.0/24 của R3.

Ta thấy một phương pháp dễ dàng dàng: từ R1 đi đến mạng 192.168.3.0/24 của R3 vẫn đi qua các đường links Fast Ethernet gồm cost = 1, serial có cost là 64 với link Fast Ethernet có cost bởi 1. Vậy tổng cost tích điểm đã là một trong + 64 + 1 là 66. Metric từ R1 đến mạng 192.168.3.0/24 là 66.

Tuy nhiên vấn đề tính tân oán vẫn trsống buộc phải phức hợp rộng ví như nhị cổng router ngơi nghỉ nhì đầu liên kết không đồng nhất về cực hiếm cost. ví dụ như, ta vào cổng F0/0 của R2 đổi lại giá trị cost thành 64 bằng phương pháp tấn công lệnh dưới đây bên trên cổng F0/0 của R2:

R2(config)#interface f0/0

R2(config-if)#ip ospf cost 64

Vậy câu hỏi đề ra là cùng với link Fast Ethernet nối giữa R1 cùng R2 ta chọn cost của link này là 1 trong những tốt 64? Nếu chọn là một trong những, tổng cost toàn con đường vẫn giữ lại quý hiếm nhỏng cũ là 66, nhưng mà nếu lọc là 64, tổng cost toàn đường đã là 64 + 64 + 1 là 129, hai giá trị rất khác nhau!

Hình 10 – Tổng path – cost là 66 hay 129?

Để vấn đáp được thắc mắc này, ta buộc phải nạm bề ngoài sau đâu vào vấn đề tính tổng cost cùng với OSPF:

Để tính tổng cost xuất phát điểm từ 1 router cho một mạng đích theo một mặt đường (path) như thế nào đó, ta thực hiện lần ngược trường đoản cú đích lần về cùng cùng dồn cost theo phép tắc đi vào thì cộng, đi ra thì không cùng.

Áp dụng quy tắc này đến ví dụ làm việc hình 10: nhằm tính tổng cost trường đoản cú R1 mang đến mạng 192.168.3.0/24, ta đi ngược từ bỏ mạng 192.168.3.0/24 đi về. lúc đi về ta lấn sân vào cổng F0/0 của R3, cùng giá trị cổng này (tổng cost lúc này là 1); đi ra khỏi cổng S2/0 của R3, bỏ qua mất không cộng (tổng cost vẫn chính là 1); đi tiếp vào cổng S2/0 của R2, cộng quý hiếm cổng này (hôm nay tổng cost là 1 trong + 64 = 65); đi thoát ra khỏi cổng F0/0 của R2, làm lơ không cộng (tổng cost vẫn chính là 65); đi tiếp vào cổng F0/0 của R1, cộng cực hiếm cổng này (tổng cost là 65 + 1 = 66), ngừng hành trình. Vậy tổng cost vẫn luôn là 66, Việc biến hóa quý giá cost bên trên cổng F0/0 ko ảnh hưởng gì cho path – cost từ bỏ R1 đi mang lại 192.168.3.0/24.

Hình 11 – Các cổng tđắm say gia vào quá trình tính toán path – cost cùng với OSPF.

Vậy nên với OSPF, nhằm review đúng được cost của lối đi cùng hoàn toàn có thể hiệu chỉnh cost bên trên cổng nhằm bẻ lối đi của gói tin theo ý muốn, ta rất cần được cảnh giác vào việc xác minh xem cổng làm sao trên phố đi đang tsay mê gia vào tính tân oán nhằm hiệu chỉnh đúng cổng bởi hiệu chỉnh sai trái cổng sẽ không còn mang về bất kỳ chuyển đổi gì.

Trên đây, chúng ta vẫn với mọi người trong nhà Review một số nét chính vào hoạt động của OSPF đối kháng vùng trải qua các bước buổi giao lưu của quá trình OSPF: chọn Router – id, thiết lập tình dục láng giềng, hiệp thương LSDB với tính tân oán chế tạo bảng định tuyến đường.

Tiếp theo họ thuộc Đánh Giá lại phương pháp thông số kỹ thuật OSPF trải qua ví dụ được trình bày tiếp sau đây.

Cấu hình

Hình 12 – Sơ đồ ví dụ cấu hình.

Trên hình 12 là 4 router thay mặt mang đến tứ chi nhánh không giống nhau của một doanh nghiệp: R1 mang lại chi nhánh 1, R2 cho Trụ sở 2, R3 đến Trụ sở 3 với R4 mang lại Trụ sở 4. Các interface loopback bên trên những router thay mặt đại diện cho các mạng nội bộ của mỗi Trụ sở, áp dụng các subnet bên trên R1, R2, R3 cùng R4 lần lượt là 192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24 và 192.168.4.0/24. Bốn router này đấu nối với nhau thông sang một kết nối multi – access (thay mặt đại diện bằng một Ethernet Switch), áp dụng subnet là 192.168.123.0/24 (bên trên thực tế, phía trên rất có thể là 1 trong môi trường Metro net đấu nối giữa những đưa ra nhánh). Router R3 với R4 còn tiến hành đấu nối riêng rẽ cùng nhau bằng một con đường leased – line trải qua những cổng serial, áp dụng subnet 192.168.34.0/24.

Yêu cầu đưa ra là chạy định đường OSPF đảm bảo an toàn hầu như can dự trên sơ đồ gia dụng này thấy nhau.

Để thực hiện chạy OSPF trên những router, chúng ta thực hiện câu lệnh sau:

R(config)#router ospf process-id

R(config-router)#network liên quan IP wildcard-mask area area-id

Trong đó:

Process – id: số hiệu của quy trình OSPF điều khiển xe trên router, chỉ có chân thành và ý nghĩa local trên router

Để cho một cổng tmê say gia OSPF, ta thực hiện “network” xúc tiến mạng của cổng đó. Với OSPF ta buộc phải thực hiện thêm wildthẻ – mask để lấy đúng mực subnet ttê mê gia định tuyến đường. Ta cũng đề nghị chỉ ra rằng links ở trong area như thế nào bằng tđê mê số “area”.

Cấu hình trên các router:

Trên router R1:

R1(config)#router ospf 1

R1(config-router)#network 192.168.123.0 0.0.0.255 area 0

R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Trên router R2:

R2(config)#router ospf 1

R2(config-router)#network 192.168.123.0 0.0.0.255 area 0

R2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Trên router R3:

R3(config)#router ospf 1

R3(config-router)#network 192.168.123.0 0.0.0.255 area 0

R3(config-router)#network 192.168.34.0 0.0.0.255 area 0

R3(config-router)#network 192.168.3.0 0.0.0.255 area 0

Trên router R4:

R4(config)#router ospf 1

R4(config-router)#network 192.168.123.0 0.0.0.255 area 0

R4(config-router)#network 192.168.34.0 0.0.0.255 area 0

R4(config-router)#network 192.168.4.0 0.0.0.255 area 0

Ta thấy Lúc ao ước cho cổng F0/0 bên trên router tmê mệt gia OSPF , ta “network” mạng 192.168.123.0/24 bên trên cổng này. Giá trị wildcard – mask được tính mang lại /24 đã là 0.0.0.255 (để tính được giá trị wildthẻ mask, ta rước quý hiếm 255.255.255.255 trừ đi giá trị subnet – mask 255.255.255.0 từng octet một sẽ được hiệu quả đề xuất search. Cách tính này chỉ hợp lý cho một dải IPhường liên tục, không phải chuẩn cho các trường đúng theo. Về wildcard – mask sẽ có một nội dung bài viết khác đề cập cụ thể mang đến vấn đề này). Tương từ cùng với các cổng khác của các router.

Kiểm tra bằng phương pháp hiển thị bảng định tuyến đường của những router:

Trên R1:

R1#sh ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 via 192.168.123.4, 00:00:29, FastEthernet0/0

O 192.168.34.0/24 via 192.168.123.4, 00:00:29, FastEthernet0/0

via 192.168.123.3, 00:00:29, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 via 192.168.123.2, 00:00:29, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 via 192.168.123.3, 00:00:29, FastEthernet0/0

Trên R2:

R2#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 via 192.168.123.4, 00:01:trăng tròn, FastEthernet0/0

O 192.168.34.0/24 via 192.168.123.4, 00:01:20, FastEthernet0/0

via 192.168.123.3, 00:01:20, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 via 192.168.123.1, 00:01:trăng tròn, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 via 192.168.123.3, 00:01:20, FastEthernet0/0

Trên R3:

R3#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 via 192.168.123.4, 00:02:07, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 via 192.168.123.1, 00:02:07, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 via 192.168.123.2, 00:02:07, FastEthernet0/0

Trên R4:

R4#show ip route ospf

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 via 192.168.123.1, 00:21:57, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 via 192.168.123.2, 00:21:57, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 via 192.168.123.3, 00:21:57, FastEthernet0/0

Ta thấy rằng những subnet sinh sống xa đã có được học tập thông qua OSPF (các route OSPF được ký hiệu bằng cam kết từ “O”).

Một điểm lạ mắt chúng ta xem xét là những mạng loopback Khi hiển thị vào bảng định đường của các router gần như được OSPF chuyển thành /32. Đây là một trong đường nét trong hoạt động của giao thức OSPF, một các loại giao thức hỗ trợ cho từng router một cái nhìn tổng quan toàn mạng chđọng không hẳn chỉ nhờ vào “tin đồn được lan truyền” nhỏng với Distance – vector. Với ánh nhìn như thế, từng router xác định được mạng loopbaông xã vị trí một cổng ko đấu nối đi đâu cả và chỉ còn gồm một cửa hàng của tất cả một mạng được sử dụng. /32 được áp dụng để phản ánh vấn đề này. Để khắc phục hiện tượng kỳ lạ này và khiến cho các subnet loopbaông xã được hiển thị đúng giá trị prefix –length, ta biến đổi hình dạng network – type trên interface loopbachồng thành đẳng cấp “point – to lớn – point” bằng câu lệnh:

R(config)#interface loopbaông xã 0

R(config-if)#ip ospf network point-to-point

Chi tiết về các “network – type “ được sử dụng vào OSPF sẽ tiến hành nói trong các nội dung bài viết khác vào độ lớn của chương trình CCNP.

Ta thuộc điều tra bảng neighbor trên các router:

Trên R4:

R4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.3.1 0 FULL/ – 00:00:34 192.168.34.3 Serial2/0

192.168.1.1 1 FULL/DROTHER 00:00:32 192.168.123.1 FastEthernet0/0

192.168.2.1 1 FULL/DROTHER 00:00:34 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:37 192.168.123.3 FastEthernet0/0

Ta thấy, R4 sẽ tùy chỉnh thiết lập quan hệ giới tính nhẵn giềng cùng với các router còn sót lại. Qua cổng F0/0, nó thấy 03 router bóng giềng có router – id là 192.168.1.1, 192.168.2.1, 192.168.3.1. Tình trạng quan hệ cũng chỉ rõ quan hệ là dạng FULL cùng vai trò của những router bóng giềng vào môi trường multi – access. Từ tác dụng show sinh hoạt bên trên, ta thấy hết sức cụ thể router R1 (192.168.1.1), R2 (192.168.2.1) là các DROther router, R3 (192.168.3.1) là BDR router cùng dĩ nhiên, ta có thể suy ra được R4 chính là DR router. DR tùy chỉnh quan hệ tình dục dạng FULL với toàn bộ các router trong môi trường thiên nhiên multi – access.

Ta cũng thấy rằng R4 cũng tùy chỉnh quan hệ nam nữ trơn giềng dạng FULL với R3 qua cổng serial 2/0. Vì đây là cổng point – to lớn – point yêu cầu các router không thai lựa chọn DR cùng BDR cùng quan hệ giới tính giữa nhì router được ký hiệu là FULL/-.

Trên R1:

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.2.1 1 2WAY/DROTHER 00:00:30 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:32 192.168.123.3 FastEthernet0/0

192.168.4.1 1 FULL/DR 00:00:31 192.168.123.4 FastEthernet0/0

Trên hiệu quả show của R1, ta cũng thấy các trơn giềng R2 (192.168.2.1), R3(192.168.3.1) với R4 (192.168.4.1) và vai trò của từng con router vào môi trường multi – access. Ta để ý rằng R1 chỉ duy trì tình dục ở tại mức 2WAY với R2, cũng là một DROther tương đương nó. Hai DROther không bao giờ hiệp thương thẳng thông báo định tuyến cùng nhau bắt buộc ko bao giờ tùy chỉnh được quan hệ nam nữ dạng FULL.

Thực hiện nay kiểm soát tương tự cùng với các router R2 và R3.

Trên trên đây, họ vẫn thuộc review lại hoạt động cơ bản của giao thức OSPF vào chương trình CCNA. Đây là một trong giao thức mạnh khỏe, quy tụ nkhô hanh, chạy được bên trên phần đa mạng có bài bản béo với nhất là một giao thức chuẩn hóa có thể chạy được bên trên những sản phẩm của rất nhiều hãng sản xuất khác biệt cho nên vì vậy được áp dụng nhiều trong thực tế. Nắm vững vàng Đặc điểm hoạt động cùng cấu hình của OSPF để giúp đỡ bọn họ chấm dứt xuất sắc kỳ thi rước chứng chỉ nước ngoài CCNA cùng thỏa mãn nhu cầu xuất sắc yêu thương cấu công việc